Exotel Status Board
Home
Dashboard
BETA
27th May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [27/05/23 08:01 PM] with 'Major Outage'
Issue has been resolved at [27/05/23 08:06 PM]