BETA

20th May 2023

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/05/23 01:20 PM] with 'Partial Outage'

Issue has been resolved at [20/05/23 01:25 PM]