Exotel Status Board
Home
Dashboard
BETA
19th May 2023
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [19/05/23 11:00 PM] with 'Major Outage'
Issue has been resolved at [20/05/23 12:06 AM]