Exotel Status Board
Home
Dashboard
BETA
18th May 2023
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
Identified at [18/05/23 12:40 PM] with 'Major Outage'
Issue has been resolved at [18/05/23 12:45 PM]