Exotel Status Board
Home
Dashboard
BETA
17th May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [17/05/23 04:45 PM] with 'Major Outage'
Issue has been resolved at [17/05/23 04:50 PM]