BETA

15th May 2023

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [15/05/23 11:25 PM] with 'Major Outage'

Issue has been resolved at [15/05/23 11:35 PM]