Exotel Status Board
Home
Dashboard
BETA
15th May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [15/05/23 10:40 AM] with 'Major Outage'
Issue has been resolved at [15/05/23 10:45 AM]