Exotel Status Board
Home
Dashboard
BETA
12th May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [12/05/23 04:55 AM] with 'Major Outage'
Issue has been resolved at [12/05/23 05:11 AM]