Exotel Status Board
Home
Dashboard
BETA
10th May 2023
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [10/05/23 06:17 PM] with 'Major Outage'
Issue has been resolved at [10/05/23 06:50 PM]