Exotel Status Board
Home
Dashboard
BETA
9th May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [09/05/23 09:50 AM] with 'Major Outage'
Issue has been resolved at [09/05/23 09:55 AM]