BETA

4th May 2023

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/05/23 06:26 PM] with 'Major Outage'

Issue has been resolved at [04/05/23 06:35 PM]