Exotel Status Board
Home
Dashboard
BETA
3rd May 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [03/05/23 02:25 AM] with 'Major Outage'
Issue has been resolved at [03/05/23 02:30 AM]