Exotel Status Board
Home
Dashboard
BETA
30th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [30/04/23 11:36 PM] with 'Major Outage'
Issue has been resolved at [30/04/23 11:41 PM]