Exotel Status Board
Home
Dashboard
BETA
29th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [29/04/23 06:40 PM] with 'Major Outage'
Issue has been resolved at [29/04/23 06:45 PM]