BETA

28th April 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [28/04/23 06:35 AM] with 'Major Outage'

Issue has been resolved at [28/04/23 06:40 AM]