BETA

25th April 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [25/04/23 02:45 PM] with 'Major Outage'

Issue has been resolved at [25/04/23 02:50 PM]