BETA

24th April 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [24/04/23 04:22 PM] with 'Major Outage'

Issue has been resolved at [24/04/23 04:26 PM]