BETA

24th April 2023

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/04/23 12:42 PM] with 'Partial Outage'

Issue has been resolved at [24/04/23 12:46 PM]