Exotel Status Board
Home
Dashboard
BETA
24th April 2023
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [24/04/23 01:10 AM] with 'Major Outage'
Issue has been resolved at [24/04/23 01:55 AM]