Exotel Status Board
Home
Dashboard
BETA
20th April 2023
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [20/04/23 02:35 AM] with 'Major Outage'
Issue has been resolved at [20/04/23 02:40 AM]