Exotel Status Board
Home
Dashboard
BETA
19th April 2023
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [19/04/23 02:45 PM] with 'Major Outage'
Issue has been resolved at [19/04/23 02:50 PM]