Exotel Status Board
Home
Dashboard
BETA
19th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [19/04/23 05:30 AM] with 'Major Outage'
Issue has been resolved at [19/04/23 05:35 AM]