BETA

18th April 2023

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [18/04/23 05:45 PM] with 'Major Outage'

Issue has been resolved at [18/04/23 05:50 PM]