Exotel Status Board
Home
Dashboard
BETA
17th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [17/04/23 02:30 PM] with 'Major Outage'
Issue has been resolved at [17/04/23 02:47 PM]