Exotel Status Board
Home
Dashboard
BETA
15th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [15/04/23 07:42 PM] with 'Major Outage'
Issue has been resolved at [15/04/23 07:46 PM]