Exotel Status Board
Home
Dashboard
BETA
11th April 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [11/04/23 02:10 PM] with 'Major Outage'
Issue has been resolved at [11/04/23 02:15 PM]