BETA

7th April 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [07/04/23 09:57 PM] with 'Major Outage'

Issue has been resolved at [07/04/23 10:10 PM]