Exotel Status Board
Home
Dashboard
BETA
31st March 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [31/03/23 04:25 AM] with 'Major Outage'
Issue has been resolved at [31/03/23 04:30 AM]