Exotel Status Board
Home
Dashboard
BETA
13th March 2023
Indonesia
Issue observed for 'Incoming Calls' in Indonesia Country
2 years ago
Identified at [13/03/23 02:25 PM] with 'Major Outage'
Issue has been resolved at [13/03/23 03:25 PM]