BETA

22nd August 2016

Incoming SMS Issue observed for Incoming SMS across India

Identified at [22/08/16 04:30 PM] with 'Major Outage'

Issue has been resolved at [22/08/16 04:31 PM]