BETA

6th August 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [06/08/17 06:21 AM] with 'Partial Outage'

Issue has been resolved at [06/08/17 06:24 AM]