BETA

27th December 2022

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [27/12/22 02:56 AM] with 'Partial Outage'

Issue has been resolved at [27/12/22 03:10 AM]