BETA

20th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [20/08/16 05:07 PM] with 'Major Outage'

Issue has been resolved at [20/08/16 05:10 PM]