BETA

21st November 2022

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [21/11/22 08:10 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/11/22 09:15 PM]