Exotel Status Board
Home
Dashboard
BETA
21st November 2022
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [21/11/22 07:56 PM] with 'Major Outage'
Issue has been resolved at [21/11/22 08:55 PM]