BETA

20th November 2022

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [20/11/22 11:15 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/11/22 04:21 AM]