BETA

10th November 2022

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [10/11/22 04:46 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [10/11/22 05:50 PM]