BETA

13th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/03/19 03:13 AM] with 'Partial Outage'

Issue has been resolved at [13/03/19 03:16 AM]