BETA

9th October 2022

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [09/10/22 12:40 AM] with 'Partial Outage'

Issue has been resolved at [09/10/22 09:35 AM]