BETA

20th August 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [20/08/16 12:13 AM] with 'Partial Outage'

Issue has been resolved at [20/08/16 12:30 AM]