BETA

6th October 2022

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [06/10/22 05:55 AM] with 'Partial Outage'

Issue has been resolved at [06/10/22 06:30 AM]