BETA

27th September 2022

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [27/09/22 11:55 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/09/22 01:40 AM]