BETA

6th August 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [06/08/17 12:36 AM] with 'Major Outage'

Issue has been resolved at [06/08/17 12:37 AM]