Exotel Status Board
Home
Dashboard
BETA
18th September 2022
West Bengal
Issue observed for 'Incoming Calls' in West Bengal Region
Identified at [18/09/22 11:00 PM] with 'Major Outage'
Issue has been resolved at [19/09/22 02:35 AM]