Exotel Status Board
Home
Dashboard
BETA
14th September 2022
Indonesia
Issue observed for 'Outgoing Calls' in Indonesia
Identified at [14/09/22 09:50 PM] with 'Major Outage'
Issue has been resolved at [14/09/22 10:00 PM]