BETA

2nd August 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/08/17 03:51 PM] with 'Major Outage'

Issue has been resolved at [02/08/17 03:53 PM]