Exotel Status Board
Home
Dashboard
BETA
4th August 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
3 years ago
Identified at [04/08/22 07:15 PM] with 'Major Outage'
Issue has been resolved at [04/08/22 07:20 PM]