BETA

19th August 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [19/08/16 11:39 PM] with 'Partial Outage'

Issue has been resolved at [20/08/16 12:10 AM]