BETA

2nd August 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [02/08/17 01:20 PM] with 'Partial Outage'

Issue has been resolved at [02/08/17 02:18 PM]