Exotel Status Board
Home
Dashboard
BETA
30th June 2022
Andhra Pradesh
Issue observed for 'Outgoing Calls' in Andhra Pradesh Region
Identified at [30/06/22 04:20 PM] with 'Major Outage'
Issue has been resolved at [30/06/22 04:25 PM]